insideforum
werbung



Zurück   digitalvideoschnitt.de - das Videoschnitt- und Camcorder-Forum > Software > Sonstige Software
Sonstige Software Fragen zu Software, die nicht in eines der obigen Foren passt
Antwort
 
LinkBack Themen-Optionen
  #1 (permalink)  
Alt 16.10.2016, 23:24
Wichtelchen2006 Wichtelchen2006 ist offline
Neuer Benutzer
Einfacher Camcorder, Iphone, Ipad, Windows-PC^^
 
Registriert seit: 07.06.2013
Beiträge: 6

Standard TV+MP4 = nur Probleme :-(


Hallo Forum,

erst einmal zur Vorgeschichte.

ich drehe viele Filme, schneide sie, speichere sie.

Es sind Privataufnahmen. Selten kinotauglich ausproduziert, sondern eher so Spontanfilme, die für mich und mein Umfeld wertvoll sind.

Zudem archiviere ich solche Privatfilme von anderen aus meinem familären Umfeld.

Ich verwalte sozusagen das Archiv für solche Videos.

Ich speichere dabei jedes Video mit folgenden Specs:

HD (sofern vorhanden):
- MP4
- Video: MPEG4-AVC (-qrf 22)
- Ton 1: MP3 256kbps (AAC hat irgendwie immer eine schlechtere Tonqualität bei gleicher Bitrate und klingt vergleichsweise "hohl")
- Ton 2: AAC 64kbps Mono (Stark radiotauglich gemasterte Version für meinen Großvater mit Hörschaden. Je weniger Dynamikumfang, desto verständlicher für ihn).

SD (immer und von jedem Video):
- AVI
- Video MPEG4-ASP
- Anamorphes 720x576 bzw. 720x480 (seltener 640x480 mit einer SAR von 1:1. Das sind eher alte Filme, die ursprünglich als DivX-Videos gespeichert wurden und die ich erst kürzlich auf MPEG4-ASP umcodiert habe, weil der DivX-Standard kaum noch unterstützt wird und ich diesen letztlich aus meinem Archiv verbannt habe)
- 3000-4000 kbps VBR
- Ton 1: Dieselbe Tonspur aus der HD-Version
- Ton 2: Wie HD-Version, allerdings MP3 statt AAC

Die SD's laufen. Da gibt es nur manchmal Probleme mit dem Anamorphen.

Die HD's machen richtig ärger:
- Die Framerate weicht bei manchen Dateien von der Ursprungsdatei ab und es sind kurioserweise ein paar Frames mehr oder weniger. (z.B. Ein 29.97fps wir mal eben zum 29.955f14ps...). Das passiert auch gerne mal, wenn ich von MP4 auf MKV umkopiere, ohne die Streams neu zu kodieren
- Bild und Ton laufen auf dem TV meines Großvaters auseinander, wenn man spult
- Einige Filme ruckeln (Aus den Frames 1,2,3,4,5 wird z.B. 1,2,2,2,5) - ebenfalls oftmals dann, wenn ich mit ffmpeg verlustfrei in mkv umpacke.
- Der Ton schwimmt stark von leise nach laut nach leise, als würde da ständig einer regeln
- Der Ton ist hackig - Nur jede zweite bis dritte Silbe wird abgespielt
- Die ersten paar Frames bestehen nur aus lila Klötzchen (nur auf meinem TV)

Im VLC-Player oder auch mit anderen PC-Software-Playern spielen die Dateien, als wäre die Welt in Ordnung (bis auf das mit den leichten Framerate-Abweichungen, was für das Brennen auf eine DVD oder der Rückwandlung in das alte DivX wieder neue Probleme bereitet).

Die Dateien wurden über die Jahre hinweg mit verschiedenen Programmen geschnitten und erzeugt:
- VideoPad diverse Versionen von 2.4 bis heute
- Magix-Schneideprogramm (benutzt mein Opa für seine Videos)
- Windows Movie Maker (Die Versionen aus XP, Vista, und Win7)
- AviDemux 2.5.6 (aktuell im Einsatz)
- AviDemux 2.6 (zerstörte mir bisher jede Tonspur völlig)

Alle SD-Versionen (die ich wegen der Probleme inzwischen bevorzuge) habe ich mit AviDemux 2.5.6 erzeugt und die laufen alle perfekt.

HD und MP4 machen mir keinen Spaß. Ich traue dem Format überhaupt nicht mehr.

Jetzt kommts:
Wenn ich die MP4 mit ffmpeg.exe erneut kodiere, erhalte ich eine Datei, die wieder eine andere Anzahl Frames und eine leicht andere Framerate hat als das Original, aber dafür eine, die wesentlich weniger Probleme bereitet.

Ich hasse MP4. Ich habe damit nur pech... AVI/MPEG4-ASP war viel einfacher und unproblematischer. Letzteres hat in meiner Gegenwart noch NIE ein Player abgelehnt oder falsch abgespielt.

Aber ganz oft musste ich dagegen schon bei der Vorführung am TV dann doch die gute alte AVI reinschmeißen, weil die MP4 spätestens auf der Hälfte der W'iedergabe versagt hat. Nur das mit dem Anamorph gab hin und wieder mal Probleme, aber man konnte den Film notfalls mit Eierköpfen gucken. Aber man konnte ihn bis zuende gucken...

MKV, das ich lieber verwenden würde, macht es übrigens nicht besser. Die Probleme sind dieselben.

MP4 soll die Zukunft sein. Ich fürchte bereits, AVI wird irgendwann nicht mehr abspielbar sein.

Wie mache ich das?

MP4 = wahre Horrorvideos

Ich habe viel geschrieben :-(.

Ich hoffe, ihr könnt mir helfen.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #2 (permalink)  
Alt 16.10.2016, 23:57
Jörg2 Jörg2 ist offline
Erfahrener Benutzer
 
Registriert seit: 23.02.2005
Beiträge: 8.097

Standard AW: TV+MP4 = nur Probleme :-(


Zitat:
Ich hasse MP4. Ich habe damit nur pech...
mag hart klingen, ist aber so...
Du hast absolut keinen Plan, wie man Material aufbereitet, ob es nun fürs Archiv, im Hometheater oder zur Oscarverleihung dienen soll.
Kauf dir ein vernüftiges Schnittprogramm, büffel die Grundlagen, frage dann gezielt nach.
Für jedes Prog gibt es Spezialisten, hier oder anderswo, die bei Problemlösungen helfen werden.
Dein workflow oben ist eine Katastrophe, so wird Hilfe nicht möglich sein, das Durcheinander ist zu groß.
Vielleicht kann dein Großvater Ordnung in deinen Wirrwarr bringen, der hat wenigsten ein Schnittprogramm...
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #3 (permalink)  
Alt 17.10.2016, 00:24
Wichtelchen2006 Wichtelchen2006 ist offline
Neuer Benutzer
Einfacher Camcorder, Iphone, Ipad, Windows-PC^^
 
Registriert seit: 07.06.2013
Beiträge: 6

Standard AW: TV+MP4 = nur Probleme :-(


Oh je...

was ist da jetzt so durcheinander?

1. Unkomprimierte Datei aus dem geschnittenen Film erzeugen.
2. Unkomprimierte Datei in AviDemux oder in eines der anderen genannten Programme laden -> MP4 mit den oben genannten Specs exportieren -> Laufen nicht (Genau hier liegt mein Anliegen an euch, warum das passiert)
3. Direkt im Anschluss mit derselben Masterdatei (meistens ohne erneutes Laden) -> als AVI mit oben genannten Specs exportieren -> Laufen perfekt.
4. Evtl. das ganze nochmal für ne DVD. Laufen ebenfalls problemlos.

Kann also nicht am Videoschneideprogramm liegen, weil der Film in den meisten Fällen bereits längst geschnitten worden ist, bevor dieses Problem auftritt. Habe daher nicht beschrieben, womit die Videos geschnitten worden sind.

Zitat:
Vielleicht kann dein Großvater Ordnung in deinen Wirrwarr bringen, der hat wenigsten ein Schnittprogramm...
Ich auch. Nämlich genau das gleiche... Habe es nur nicht erwähnt. Aber ich benutze trotzdem lieber VideoPad.
Seine Filme haben übrigens dasselbe Problem, obwohl ich die Dateien nicht verändert habe...

Ich habe nur die Programme aufgelistet, die über Jahre (ca. 10) verwendet worden sind, weil es vielleicht hilfreich sein könnte.

*augenroll*

Edit:

Ich habe gerade mal die Fehlersuche von ffmpeg.exe ausprobiert und alle MP4 haben den folgenden Fehler:

[mp3 @ 0326dbc0] Header missing
Error while decoding stream #0:1: Invalid data found when processing input

Anscheinend fehlt den Dateien was. Aber was?

Geändert von Wichtelchen2006 (17.10.2016 um 00:58 Uhr).
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #4 (permalink)  
Alt 18.10.2016, 19:51
mittendrin mittendrin ist offline
Benutzer
 
Registriert seit: 28.10.2008
Ort: Recklinghausen
Beiträge: 342

Standard AW: TV+MP4 = nur Probleme :-(


Du musst dem Encodierungsprogramm, dass dir die Filme in MP4 encodiert genau sagen, wie es das tun soll. MP4 ist eine richtig gute Angelegenheit, muss aber eben richtig eingestellt sein.

Deswegen wies Jörg auch auf Grundlagen hin.

ffmpeg ist leider nicht mein Ding, kann dir da auch nicht helfen.

Ein AVI PAL läuft natürlich auf dem Fernseher.

Stelle doch mal zur Probe sicher, dass dein MP4 auch mit Halbbildern und 25 fps gerendert ist, falls nicht so bereits gemacht.

1: Welche Formate kann das benutzte Fernsehgerät abspielen?

2: Welche HD-Formate nutzt du?

3: Spielst du Filme in HD z.B. von einem USB-Stick ab?
__________________
Gruß, Matthias
------------------------------------------------------------------------
"Hubraum ist durch nichts zu ersetzen als durch noch mehr Hubraum." Cadillac
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #5 (permalink)  
Alt 19.10.2016, 18:28
Wichtelchen2006 Wichtelchen2006 ist offline
Neuer Benutzer
Einfacher Camcorder, Iphone, Ipad, Windows-PC^^
 
Registriert seit: 07.06.2013
Beiträge: 6

Standard AW: TV+MP4 = nur Probleme :-(


Danke für deine Antwort.

Zitat:
Du musst dem Encodierungsprogramm, dass dir die Filme in MP4 encodiert genau sagen, wie es das tun soll. MP4 ist eine richtig gute Angelegenheit, muss aber eben richtig eingestellt sein.
Habe die Standardeinstellungen genommen. Der Codec war x264. Den crf-Einstellung habe ich auf 20 gesetzt.

Zitat:
Deswegen wies Jörg auch auf Grundlagen hin.
Mag sein, er hat sich dabei aber mächtig im Ton vergriffen!

Zitat:
Stelle doch mal zur Probe sicher, dass dein MP4 auch mit Halbbildern und 25 fps gerendert ist, falls nicht so bereits gemacht.
Keine Besserung :-(.
Habe allerdings einen vorhandenen progressiven Film entsprechend umgewandelt, da hier einfach niemand ne HD-Cam hat, die 50i filmt.

Weder Interlaced noch Progressive.
Habe 1280x720 und 50i bzw. 25p versucht. Top Field First und Bottom Field first.
Mein TV kann 1080i50 offiziell nicht :-D.

Zitat:
1: Welche Formate kann das benutzte Fernsehgerät abspielen?
Mein TV (BJ 2009): MPEG1, MPEG2, MPEG4 und DivX
Opas TV (BJ 2014): MPEG2, MPEG4, H.263, VCD, 3OGG

Mein DVD-Player (BJ 2008): MPEG4 (Dort geht es, wie ich zwischenzeitig festgestellt habe!)

Sollte also eigentlich klappen.

Zitat:
Welche HD-Formate nutzt du?
HD:
Derzeit gibt es in meiner Sammlung:
- 1080p30 (29,97)
- 1080p24 (23,976)
- 720p30 (29,97)
- 720p18 (War mal so ein "Ratterfilm" aus den 70ern. Der hatte diese Framerate)

SD (läuft alles):
- 576p25 (Nur ein schlechtes Video bisher, welches auch noch ruckelt xD Kein Maßstab zum Testen.)
- 480p30 (29,97, anamorph)
- 480i60 (59.94, anamorph)
- 640x480 (29,97, 23,976, 15)

Die Auflösungen und Framerates wurden idr. von dem verwendeten Kameras übernommen.

Zitat:
3: Spielst du Filme in HD z.B. von einem USB-Stick ab?
Ja. Genutzt werden Stick, HDD und manchmal auch Daten-DVD.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #6 (permalink)  
Alt 20.10.2016, 19:39
mittendrin mittendrin ist offline
Benutzer
 
Registriert seit: 28.10.2008
Ort: Recklinghausen
Beiträge: 342

Standard AW: TV+MP4 = nur Probleme :-(


"crf-Einstellung"

Was ist das?

Du musst bei deiner Software die Bandbreite für Video und Audio so einstellen, dass das Ergebnis für eure TVs funktioniert.

Wenn du nur "crf" einstellen kannst und dieses crf-Ding von sich aus irgendwelche Werte nimmt, die evtl. nur auf PCs laufen, benötigst du eine andere Software für mp4.

Die Frage nach dem USB kam, weil zumindest bei Videos mit hohen Bandbreiten für z.B. Full HD oder mehr der Stick unbedingt USB3-Geschwindigkeiten bieten muss.
__________________
Gruß, Matthias
------------------------------------------------------------------------
"Hubraum ist durch nichts zu ersetzen als durch noch mehr Hubraum." Cadillac
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #7 (permalink)  
Alt 21.10.2016, 02:20
Wichtelchen2006 Wichtelchen2006 ist offline
Neuer Benutzer
Einfacher Camcorder, Iphone, Ipad, Windows-PC^^
 
Registriert seit: 07.06.2013
Beiträge: 6

Standard AW: TV+MP4 = nur Probleme :-(


crf nicht bekannt? Constant Rate Factor?

Ich merke schon.

Ich bin hier im völlig falschen Forum.

Hier kann mir keiner helfen, wenn die essentiellsten Parameter von MPEG-AVC hier scheinbar gänzlich unbekannt sind.

Darum ist die Beteiligung auch so gering und man hat mich beschimpft, dass ich keine Ahnung von nichts hätte. Vermutlich, weil der Text einfach nicht verstanden worden ist.

Hat sich somit erledigt.

Habe das Problem sowieso inzwischen gelöst - Eine andere Community hat mit viel mehr fachlicher Hilfe geglänzt.

Zur Info, da es hilfreich sein könnte, woran es lag:

Wenn in der Bedienungsanleitung eines TV-Gerätes "MPEG4" aufgelistet wird. ist damit meist nur der kleine Bruder MPEG4-ASP gemeint.

Dies habe ich nicht gewusst. Habe das so interpretiert, dass damit beide Formen von MPEG4 (sowohl ASP und AVC) gemeint sind.

Bei meinem DVD-Player, wo es funktioniert, war das wohl auch so gemeint.

Also mehr Werbung als Realität in der technischen Detailauflistung des Fernsehers.

Dann funktioniert das natürlich nicht, weil die TV-Geräte das einfach nicht abspielen können, da schlichtweg kein brauchbarer Decoder dafür an Board ist.

Die Fernseher meiner Bekannten sind einfach zu dumm dafür.

Bin mit einer Probedatei in ein Elektrofachgeschäft gegangen. Die heutigen Fernseher haben weit weniger Probleme damit.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #8 (permalink)  
Alt 21.10.2016, 09:27
Jörg2 Jörg2 ist offline
Erfahrener Benutzer
 
Registriert seit: 23.02.2005
Beiträge: 8.097

Standard AW: TV+MP4 = nur Probleme :-(


weil dir mein Ton sowieso nicht passt...

du bist nicht im falschen Forum, du kannst dich nur nicht artikulieren.
Deine Fehlersuche ist derartig unterirdisch formuliert, mit wirren Halbsätzen versehen, unsäglichen Wertungen:
Zitat:
HD und MP4 machen mir keinen Spaß. Ich traue dem Format überhaupt nicht mehr.
Zitat:
Ich hasse MP4. Ich habe damit nur pech
Zitat:
MP4 = wahre Horrorvideos
und auf dieses Sammelsurium an haltlosen Vorwürfen kam mein Tip, sich um die Grundlagen zu kümmern...dass du deine clips dann auch noch auf untauglichen TVs wiedergibst...
Zitat:
Die Fernseher meiner Bekannten sind einfach zu dumm dafür.
die TV jedenfalls sind sicher nicht zu dumm, höchstens zu alt...

Zitat:
Ich bin hier im völlig falschen Forum.
blätter hier mal ruhig rum, gerne so ein Jahrzehnt, lese mal die Probleme und deren (meist) erfolgreichen Lösungen.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #9 (permalink)  
Alt 21.10.2016, 10:24
mittendrin mittendrin ist offline
Benutzer
 
Registriert seit: 28.10.2008
Ort: Recklinghausen
Beiträge: 342

Standard AW: TV+MP4 = nur Probleme :-(


Also, hör mal ...

Die Kombi aus fehlendem Basiswissen und dem Benutzen halbseidener Software ist die eine Sache.

Auch, wenn ich zu 100% nachvollziehen kann, dass einen ein Problem echt Nerven kann:

Aber sich scheinbar zu weigern sich in das Basiswissen einzulesen, u.a. in das zu deiner Software, dann auch dabei auf den absoluten Standard der Videowelt, u.a. von YouTube und Vimeo, zu schimpfen eben weil man keinen Plan hat, finde ich schon ziemlich daneben.

Vielleicht bist du hier im falschen Forum. Gut, dass dir andere helfen konnten.

Ich z.B. benutze leider keine Software, die mir deinen Worten nach nur eine Einstellung für die Encodierung zu MP4 bereitstellt.

Vielleicht beruht es auch auf Gegenseitigkeit und MP4 traut dir nicht mehr?
__________________
Gruß, Matthias
------------------------------------------------------------------------
"Hubraum ist durch nichts zu ersetzen als durch noch mehr Hubraum." Cadillac

Geändert von mittendrin (21.10.2016 um 10:53 Uhr).
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
  #10 (permalink)  
Alt 01.12.2016, 16:13
gowmiuso gowmiuso ist offline
Neuer Benutzer
PC
 
Registriert seit: 01.12.2016
Beiträge: 2

Standard AW: TV+MP4 = nur Probleme :-(


Stelle doch mal zur Probe sicher, dass dein MP4 auch mit Halbbildern und 25 fps gerendert ist, falls nicht so bereits gemacht.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Mit Zitat antworten
Antwort



Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
1080p50 Material - Probleme mit m2ts Dateien (grünes Vorschaubild) Grintolix Adobe Premiere inkl. Encore DVD 1 02.06.2015 19:12
Große Probleme beim Export von MP4 Material PatDie Magix Software 8 13.02.2013 15:55
Probleme bei der Installation der Terratec Grabster AV400 Mobile gustavlampe sonstige Hardware 0 25.02.2005 08:22


Alle Zeitangaben in WEZ +1. Es ist jetzt 09:11 Uhr.


Powered by vBulletin® Version 3.8.7 (Deutsch)
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

SEO by vBSEO 3.0.0 RC8